ورود به حساب ثبت نام جدید فراموشی کلمه عبور
برای ورود به حساب کاربری خود، نام کاربری و کلمه عبورتان را در زیر وارد کرده و روی «ورود به سایت» کلیک کنید.





اگر فرم ورود برای شما نمایش داده نمیشود، اینجا را کلیک کنید.









اگر فرم ثبت نام برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.









اگر فرم بازیابی کلمه عبور برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.





کاربران برچسب زده شده

صفحه 1 از 2 12 آخرین
نمایش نتایج: از 1 به 10 از 14

موضوع: مشکل در ise

  1. #1
    2015/12/15
    15
    1

    مشکل در ise

    سلام من به این نرم افزار زیاد وارد نیستم ولی به کمک یکی از استاتید همین سایت پروژه ای انجام شد

    ولی الان مشکلی که هست تو isim وقتی میخوام شبیه سازی کنم اصلا اتفاقی نمیافته !

    الان این قسمت هایی که تو عکس مشخص کردم تو شبیه سازی خود ایشون صفر و. ... هست که عکسشم گذاشتم اما تو اجرای من u نوشته value رو !

    و دیگه اینکه برای ایشون شبیه سازی بدون مشکل انجام شده همونطور که در عکس میبینید ولی برای من اصلا هیچ اتفاقی در اون بلوک هایی که با قرمز مشخص کردم تو دو تا عکس نمی افته ! خیلی فوریه تو رو خدا راهنمایی کنید

    عکس من



    عکس ایشون






    اضافه شده در تاریخ :
    بچه ها کسی نمیتونه کمک کنه خیلی نیاز دارم

    اضافه شده در تاریخ :
    آقای غفار زاده نمیخوام نقض قانون کنم ولی به خدا کارم گیره واقعا همین الان به حل مشکلم نیاز پیدا کردم و خیلی مهمه ببخشیدتو رو خدا
  2. #2
    2013/04/24
    2,690
    2,515

    پاسخ : مشکل در ise

    آخه دوست عزیز نصف شب اونم بعد از نیم ساعت که تاپیک زدی میای و باز پست میزنی آخه یعنی چی؟؟؟؟
  3. #3
    2015/12/15
    15
    1

    پاسخ : مشکل در ise

    بچه ها کمک لطفا
  4. #4
    2014/11/30
    38
    0

    پاسخ : مشکل در ise

    سلام
    اگر دقت کنید شما اصلا clk ندارید!!!
    داخل test bench با یک بلوک always ابتدا clk مورد نظرتونا بسازید........

    اگه کد هر دو شبیه سازی یکی هست پس داخل test bench نوشتن به مشکل دارید

    مسئله دیگه ای هم مطرح هست اینکه عکس اول زمانش با تصویر دوم خیلی فرق داره!!!!!
    زمان شبیه سازی کد اول هم بیشتر بکنید
  5. #5
    2015/12/15
    15
    1

    پاسخ : مشکل در ise

    این کده :


    library IEEE;
    use IEEE.STD_LOGIC_1164.ALL;

    entity led4 is
    Port ( clk : in STD_LOGIC;
    res : in STD_LOGIC;
    led : out STD_LOGIC_VECTOR (3 downto 0));
    end led4;

    architecture Behavioral of led4 is

    type state is(s1,s2);
    signal st: state;

    signal x: std_logic_vector(3 downto 0);

    begin

    process(clk,res)
    variable i: integer range 0 to 16000000;
    begin


    if(res='1&#039then
    i:=0;
    led<="0000";
    x<="0000";
    st<=s1;
    elsif(clk'event and clk='1&#039then
    i:=i+1;
    if(i>15)then ------- kahesh ferequency baraye simoole, baraye test vagheyii bayad 15999999 shavad
    i:=0;
    if(st=s1)then
    x<=x(2 downto 0)&'1';
    led<=x;
    if(x="1111&quotthen
    st<=s2;
    end if;
    else
    x<='0'&x(3 downto 1);
    led<=x;
    if(x="0000&quotthen
    st<=s1;
    end if;
    end if;
    end if;
    end if;

    end process;

    end Behavioral;

    ایشونم با همین کد به این سیمولیت رسیدن الان دقیقا میتونید بگید چیکار کنم ؟ زمانم که هر دوشون 990 us هست دیگه باید چیکار کنم دقیقا ؟

    اینم پروژه میشه حلش کنی واسم به خدا همین الان نیاز دارم
    ممنون میشم

    http://s7.picofile.com/file/8233303818/4led.rar.html
  6. #6
    2014/11/30
    38
    0

    پاسخ : مشکل در ise

    به جای کد test bench خودت کد زیرا بزن

    کد:
    LIBRARY ieee;
    USE ieee.std_logic_1164.ALL;
    
    ENTITY tb1 IS
    END tb1;
     
    ARCHITECTURE behavior OF tb1 IS 
     
      -- Component Declaration for the Unit Under Test (UUT)
     
      COMPONENT led4
      PORT(
         clk : IN std_logic;
         res : IN std_logic;
         led : OUT std_logic_vector(3 downto 0)
        );
      END COMPONENT;
      
    
      --Inputs
      signal clk : std_logic := '0';
      signal res : std_logic := '0';
    
     	--Outputs
      signal led : std_logic_vector(3 downto 0);
    
      -- Clock period definitions
      constant clk_period : time := 10 ns;
     
    BEGIN
     
    	-- Instantiate the Unit Under Test (UUT)
      uut: led4 PORT MAP (
         clk => clk,
         res => res,
         led => led
        );
    
      -- Clock process definitions
      clk_process :process
      begin
    		clk <= '0';
    		wait for clk_period/2;
    		clk <= '1';
    		wait for clk_period/2;
      end process;
    
    
      -- Stimulus process
      stim_proc: process
      begin		
       res<='1';
       wait for 100 ns;
       res<='0';
       wait for 200 us;	
    
       wait for clk_period*200;
    
       -- insert stimulus here 
    
       wait;
      end process;
    
    END;
  7. #7
    2015/12/15
    15
    1

    پاسخ : مشکل در ise

    ممنون - دستور waite for کارش چیه؟

    میشه یه توضیحی بدید ؟ خطوط دستور رو لطفا
  8. #8
    2014/11/30
    38
    0

    پاسخ : مشکل در ise

    الان جواب گرفتید دیگه؟
    این دستور باعث میشه تا زمان روبروش نگذشته باشه خطوط بعدی اجرا نشن
  9. #9
    2015/12/15
    15
    1

    پاسخ : مشکل در ise

    ممنون ولی - الان بازم مشکل هست

    اینکه led ها تو سیمولیت هنوز u هستند و سیگنال ندارند

    http://s7.picofile.com/file/8233310350/sd.jpg
  10. #10
    2014/11/30
    38
    0

    پاسخ : مشکل در ise

    همین الان کدا چک کردم
    فقط کدا کوپی کنید تمام


    موفق باشید
صفحه 1 از 2 12 آخرین
نمایش نتایج: از 1 به 10 از 14

موضوعات مشابه

  1. مشکل - مشکل - مشکل ( حروف نا مفهوم برروی LCD)
    توسط ssaeid2000 در انجمن سایر مطالب مرتبط با ميکرو ها و پروسسورها
    پاسخ: 11
    آخرين نوشته: 2008/10/07, 17:00

کلمات کلیدی این موضوع

علاقه مندي ها (Bookmarks)

علاقه مندي ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •