ورود به حساب ثبت نام جدید فراموشی کلمه عبور
برای ورود به حساب کاربری خود، نام کاربری و کلمه عبورتان را در زیر وارد کرده و روی «ورود به سایت» کلیک کنید.





اگر فرم ورود برای شما نمایش داده نمیشود، اینجا را کلیک کنید.









اگر فرم ثبت نام برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.









اگر فرم بازیابی کلمه عبور برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.





کاربران برچسب زده شده

نمایش نتایج: از 1 به 2 از 2
  1. #1
    2015/06/10
    4
    0

    یک مشکل عجیب! شاید هم ساده!

    سلام و وقت بخیر
    آقایون داداشام
    بنده یدونه هدر برد 1768 مال eca گرفتم و روی برد خودم گذاشتم.
    برد خودم دو قسمت کلی داره : ورودی و خروجی
    اولا بگم ک، بعنوان تغذیه 5 ولت از آیسی lm2576 استفاده کردم که 24 ولت ورودیم رو به 5 ولت تبدیل میکنه.
    حالا قسمت اول برد (ورودی) : تعدادی ورودی در نظر گرفتم که به پین های 0 تا 10 پورت صفر وصل شدن، البته سر راه هرکدوم از پینها یدونه اپتوکوپلر 521 گذاشتم و قبل از اپتو رو هم led بهمراه مقاومت گذاشتم و البته خازن عدسی هم بعنوان فیلتر استفاده کردم. با وصل شدن ورودی اپتوکوپلر 3.3 میندازه روی پین میکرو و بعدا ازش استفاده میکنم
    قسمت دوم برد (خروجی) : کلا 5 تا رله گذاشتم که با 2803 درایو میشن و اون رله ها هم 24 ولت رو تو خروجی میندازن. برای 2803 هم مقاومتای پایین کش گذاشتم(10کیلو)

    مشکل: یدونه شیرسلونوئیدی دارم که با 24 تحریک میشه و تقریبا 0.08 آمپر هم جریان میکشه البته بعضی وقتا بصورت موقت یهویی 0.16 هم شده . حالا مشکل اینه که وقتی این شیر رو میزنم به خروجیم که با رله دارم کنترل میکنم، یهویی برنامم میره توی روتین وقفه و همینجوری کل روتین رو اجرا میکنه(حتی شروطی که اصلا برقرار نیستند) و جالبتر اینکه وقتی یک سر شیر رو به ورودی تغذیه اصلی که همون 24 ولته میزنم هم بازم همین اتفاق میوفته!!!!
    یکی کمک کنه که مشکل کجاست
  2. #2
    2011/09/26
    خراسان رضوي-مشهد
    759
    29

    پاسخ : یک مشکل عجیب! شاید هم ساده!

    میشه مدار بخش اپتوکوپلرت رو بزاری ببینم چیکار کردی
نمایش نتایج: از 1 به 2 از 2

موضوعات مشابه

  1. پاسخ: 3
    آخرين نوشته: 2013/09/02, 06:52
  2. مشکل عجیب در یک طراحی ساده
    توسط ueue در انجمن مدارهای آنالوگ و مدارهای مجتمع
    پاسخ: 9
    آخرين نوشته: 2013/01/07, 06:45
  3. یه مشکل مسخره ! شاید گاف نرم افزاری !
    توسط agape در انجمن PLD , SPLD , GAL , CPLD , FPGA
    پاسخ: 1
    آخرين نوشته: 2011/06/30, 22:26
  4. موضوعی که شاید باورتون نشه!
    توسط ali- در انجمن برنامه نویسی و اینترفیس
    پاسخ: 2
    آخرين نوشته: 2008/07/29, 00:22
  5. کمک برای یه برنامه ی خیلی ساده و بدیهی .. یه مشکل عجیب !!
    توسط hadikazemi در انجمن میکروکنترلرهای AVR
    پاسخ: 6
    آخرين نوشته: 2007/06/10, 12:48

کلمات کلیدی این موضوع

علاقه مندي ها (Bookmarks)

علاقه مندي ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •