ورود به حساب ثبت نام جدید فراموشی کلمه عبور
برای ورود به حساب کاربری خود، نام کاربری و کلمه عبورتان را در زیر وارد کرده و روی «ورود به سایت» کلیک کنید.





اگر فرم ثبت نام برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.









اگر فرم بازیابی کلمه عبور برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.





کاربران برچسب زده شده

نمایش نتایج: از 1 به 3 از 3
  1. #1
    2006/11/19
    تهران
    114
    133

    مشکل در راه اندازی UART در LPC1768

    سلام
    من از بردآموزشی ECA استفاده می کنم.
    می خوام UART0 رو راه اندازی کنم اما کاراکترهای بی معنی به کامپیوتر ارسال می شه. اما مثال LandTiger خیلی خوب کار می کنه. در حالیکه وقتی فایلهای مورد استفاده همین مثال رو توی فولدر خودم کپی می کنم و برنامه اصلیش رو هم توی برنامه خودم کپی پیست می کنم برنامه کامپایل می شه ولی در عمل بازم کاراکترهای بی معنی می فرسته.
    ممکنه راهنماییم کنین که کجای کار دارم اشتباه می کنم؟
    یعنی یه سری تنظیمات هست که نویسنده LandTiger انجام داده و من انجام ندادم؟
  2. #2
    2011/11/30
    75
    46

    پاسخ : مشکل در راه اندازی UART در LPC1768

    سلام
    کاراکتر چرت و پرت مساویس با تنظیم نبودن باودریت، که توی این مورد شما باید 2 مورد چک بشه؛ اول کلاک CPU و دوم کلاک Peripheral
    چک کنید که کلاک CPU دقیقا همونیه که توی اون مثاله، مثلا 100 مگاهرتز، و این که کلاک پریفرالا هم یکی باشه، مثلا پریفرال باشه CPU تقسیم بر 4
    موفق باشین
  3. #3
    2006/11/19
    تهران
    114
    133

    پاسخ : مشکل در راه اندازی UART در LPC1768

    خیلی ممنونم
    اما میشه بگید این دو مورد رو چطور باید تنظیم کنم؟
    من همیشه SystemInit رو میذارم و کاری به کلاک ندارم.
نمایش نتایج: از 1 به 3 از 3

موضوعات مشابه

  1. کمک در راه اندازی uart lpc1768
    توسط saeidmo در انجمن NXP
    پاسخ: 6
    آخرين نوشته: 2015/09/07, 18:12
  2. مشکل در راه اندازی هدر برد lpc1768
    توسط kamran04812 در انجمن NXP
    پاسخ: 3
    آخرين نوشته: 2015/02/15, 23:03
  3. مشکل عجیب uart در lpc1768
    توسط amintanharpd در انجمن NXP
    پاسخ: 11
    آخرين نوشته: 2014/12/22, 20:26
  4. مشکل UART در LPC1768
    توسط FarzadMGN در انجمن NXP
    پاسخ: 4
    آخرين نوشته: 2014/11/12, 00:03
  5. مشکل در راه اندازی uart
    توسط saeid bahari در انجمن میکروکنترلرهای AVR
    پاسخ: 4
    آخرين نوشته: 2013/02/03, 21:06

کلمات کلیدی این موضوع

علاقه مندي ها (Bookmarks)

علاقه مندي ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •