ورود به حساب ثبت نام جدید فراموشی کلمه عبور
برای ورود به حساب کاربری خود، نام کاربری و کلمه عبورتان را در زیر وارد کرده و روی «ورود به سایت» کلیک کنید.





اگر فرم ثبت نام برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.









اگر فرم بازیابی کلمه عبور برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.





کاربران برچسب زده شده

نمایش نتایج: از 1 به 2 از 2
  1. #1
    2007/12/29
    2
    0

    Angry اجرا نشدن برنامه بعد پروگرم کردن

    سلام خدمت دوستان گرامی
    بنده چند وقتی هست که شروع بکار با میکروهای stm32 کردم. مشکل که بنده دارم اینه که گاهی وقتا بعد از پروگرم کردن و یا اتصال تغذیه میکرو برنامه اجرا نمیشه. انقدر باید تغذیه رو قطع و وصل کنم تا اجرا بشه نمیدونم اشکال کجاست. در ضمن پروگرمر هم jlink هست که از خود شرکت eca خرید کردم. درواقع وقتی که برنامه اجرا نمیشه led پروگرامر قرمز چشمک زن میشه که در این حالت نمیتونم پروگرم کنم خطا میده. به پیشنهاد دوستان پایه boot رو هم با مقاومت زمین کردم که تاثیری نداشت . مدار ریست هم با مقاومت به تغذیه و خازن به زمین هست. میکرویی هم که استفاده میکنم stm32f105rbt6 هست. الان دیگه کلا برنامه اجرا نمیشه دیگه هرچی هم که تغذیه رو قطع و وصل میکنم درست نمیشه.
    ممنون
  2. #2
    2017/06/13
    718
    369

    پاسخ : اجرا نشدن برنامه بعد پروگرم کردن

    نقل قول نوشته اصلی توسط ttlcmos

    مهمان عزیز شما حق دیدن لینک ها را ندارید

    عضویت

    سلام خدمت دوستان گرامی
    بنده چند وقتی هست که شروع بکار با میکروهای stm32 کردم. مشکل که بنده دارم اینه که گاهی وقتا بعد از پروگرم کردن و یا اتصال تغذیه میکرو برنامه اجرا نمیشه. انقدر باید تغذیه رو قطع و وصل کنم تا اجرا بشه نمیدونم اشکال کجاست. در ضمن پروگرمر هم jlink هست که از خود شرکت eca خرید کردم. درواقع وقتی که برنامه اجرا نمیشه led پروگرامر قرمز چشمک زن میشه که در این حالت نمیتونم پروگرم کنم خطا میده. به پیشنهاد دوستان پایه boot رو هم با مقاومت زمین کردم که تاثیری نداشت . مدار ریست هم با مقاومت به تغذیه و خازن به زمین هست. میکرویی هم که استفاده میکنم stm32f105rbt6 هست. الان دیگه کلا برنامه اجرا نمیشه دیگه هرچی هم که تغذیه رو قطع و وصل میکنم درست نمیشه.
    ممنون
    سلام
    اینکه بعد از پروگرم کردن برنامه اجرا نشه طبیعیه! چون باید ریست شدن بعد از پروگرام کردن رو فعال کنید که احتمالا فعال نیست.
    البته برای خودم هم یبار همچین مشکلی پیش اومد که بعد از روشن شدن فقط یکی از تسک های RTOS اجرا میشد و باید دستی میکروکنترلر رو ریست میکردم تا درست کار کنه! بعدا هم وقت نکردم بفهمم دردش چیه. اگر کسی از دوستان میدونه لطف کنه راهنمایی کنه
نمایش نتایج: از 1 به 2 از 2

موضوعات مشابه

  1. پاسخ: 8
    آخرين نوشته: 2018/02/21, 12:59
  2. پاسخ: 14
    آخرين نوشته: 2017/06/28, 14:52
  3. داغ شدن و اجرا نشدن برنامه ATmega64A
    توسط i4man12 در انجمن میکروکنترلرهای AVR
    پاسخ: 16
    آخرين نوشته: 2015/05/17, 23:41
  4. پاسخ: 2
    آخرين نوشته: 2014/09/05, 19:17
  5. سوال در مورد اجرا نشدن مکرر برنامه
    توسط mohsen.92 در انجمن میکروکنترلرهای AVR
    پاسخ: 5
    آخرين نوشته: 2013/11/26, 06:48

کلمات کلیدی این موضوع

علاقه مندي ها (Bookmarks)

علاقه مندي ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •